comparison debian/rules @ 305:00766bc86962 noffle

[svn] removed grep
author godisch
date Sun, 16 Feb 2003 15:38:48 +0000
parents 4f4c233374ca
children a6e66cc358e8
comparison
equal deleted inserted replaced
304:9bbb4c40fe62 305:00766bc86962
1 #!/usr/bin/make -f 1 #!/usr/bin/make -f
2 # $Id: rules 436 2003-02-15 21:34:21Z godisch $ 2 # $Id: rules 439 2003-02-16 15:38:48Z godisch $
3 3
4 #export MAINT_BUILD=1 4 #export MAINT_BUILD=1
5 5
6 BUILDDIR = debian/noffle 6 BUILDDIR = debian/noffle
7 DEBDIR = $(BUILDDIR)/DEBIAN 7 DEBDIR = $(BUILDDIR)/DEBIAN
145 $(INSTALL) -m 0755 debian/postinst $(DEBDIR) 145 $(INSTALL) -m 0755 debian/postinst $(DEBDIR)
146 $(INSTALL) -m 0755 debian/postrm $(DEBDIR) 146 $(INSTALL) -m 0755 debian/postrm $(DEBDIR)
147 $(INSTALL) -m 0755 debian/preinst $(DEBDIR) 147 $(INSTALL) -m 0755 debian/preinst $(DEBDIR)
148 $(INSTALL) -m 0755 debian/prerm $(DEBDIR) 148 $(INSTALL) -m 0755 debian/prerm $(DEBDIR)
149 cd $(BUILDDIR) && find usr -type f -print0 | xargs -0 md5sum > DEBIAN/md5sums 149 cd $(BUILDDIR) && find usr -type f -print0 | xargs -0 md5sum > DEBIAN/md5sums
150 cd $(BUILDDIR) && find ./etc -type f | cut -c 2- | egrep -vx '/etc/default/noffle|/etc/news/noffle\.conf' > DEBIAN/conffiles 150 cd $(BUILDDIR) && find ./etc -type f | cut -c 2- > DEBIAN/conffiles
151 debconf-mergetemplate debian/templates.?? debian/templates > $(DEBDIR)/templates 151 debconf-mergetemplate debian/templates.?? debian/templates > $(DEBDIR)/templates
152 chown root:root $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates 152 chown root:root $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates
153 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates 153 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates
154 154
155 # building Debian package 155 # building Debian package