comparison debian/rules @ 369:31295db432f5 noffle

[svn] added upstream compatbile patching
author godisch
date Tue, 01 Apr 2003 14:47:49 +0100
parents fa7a42b18bc8
children 38f082d6856a
comparison
equal deleted inserted replaced
368:f32b79089a5e 369:31295db432f5
1 #!/usr/bin/make -f 1 #!/usr/bin/make -f
2 # $Id: rules 474 2003-03-04 20:47:54Z godisch $ 2 # $Id: rules 509 2003-04-01 13:47:49Z godisch $
3
4 #export MAINT_BUILD=1
5 3
6 BUILDDIR = debian/noffle 4 BUILDDIR = debian/noffle
7 DEBDIR = $(BUILDDIR)/DEBIAN 5 DEBDIR = $(BUILDDIR)/DEBIAN
8 DOCDIR = $(BUILDDIR)/usr/share/doc/noffle 6 DOCDIR = $(BUILDDIR)/usr/share/doc/noffle
9 SPOOLDIR = $(BUILDDIR)/var/spool/noffle 7 SPOOLDIR = $(BUILDDIR)/var/spool/noffle
39 STRIP_FLAG = -s 37 STRIP_FLAG = -s
40 endif 38 endif
41 39
42 clean: 40 clean:
43 $(testdir) 41 $(testdir)
44 -rm -f configure-stamp build-stamp debian/files debian/substvars 42 rm -f configure-stamp build-stamp debian/files debian/substvars
45 #ifneq ($(MAINT_BUILD),1)
46 # # ---------- prevent automake etc. from being called
47 # # if you have changed anything, set MAINT_BUILD to 1
48 # touch configure.in && \
49 # touch Makefile.am docs/Makefile.am src/Makefile.am packages/Makefile.am packages/redhat/Makefile.am && \
50 # touch aclocal.m4 && \
51 # touch Makefile.in docs/Makefile.in src/Makefile.in packages/Makefile.in packages/redhat/Makefile.in && \
52 # touch configure && \
53 # touch stamp-h.in config.h.in
54 # # ---------- endif
55 #else
56 # aclocal
57 # autoconf
58 # autoheader
59 # automake
60 # -rm -f config.log
61 #endif
62 -$(MAKE) -i distclean 43 -$(MAKE) -i distclean
63 -rm -rf debian/noffle 44 rm -rf debian/noffle
45 -cat debian/patches/*.diff | patch -RNtp1 -r debian/rejected --no-backup-if-mismatch
46 rm -f debian/rejected
64 47
65 configure: configure-stamp 48 configure-stamp: configure
66 configure-stamp:
67 $(testdir) 49 $(testdir)
50 -cat debian/patches/*.diff | patch -Ntp1 -r debian/rejected --no-backup-if-mismatch
68 ./configure $(CONFFLAGS) --prefix=/usr --mandir=/usr/share/man \ 51 ./configure $(CONFFLAGS) --prefix=/usr --mandir=/usr/share/man \
69 --with-configfile=/etc/news/noffle.conf \ 52 --with-configfile=/etc/news/noffle.conf \
70 --with-usersfile=/etc/news/noffle.users --enable-auth=no 53 --with-usersfile=/etc/news/noffle.users --enable-auth=no
71 touch configure-stamp 54 touch configure-stamp
72 55
73 build: build-stamp 56 build: build-stamp
74 build-stamp: configure 57 build-stamp: configure-stamp
75 $(testdir) 58 $(testdir)
76 $(MAKE) 59 $(MAKE)
77 touch build-stamp 60 touch build-stamp
78 61
79 binary: binary-arch 62 binary: binary-arch
81 binary-indep: 64 binary-indep:
82 65
83 binary-arch: build 66 binary-arch: build
84 $(testdir) 67 $(testdir)
85 $(testroot) 68 $(testroot)
86 -rm -rf debian/noffle 69 rm -rf debian/noffle
87 70
88 # installing binaries 71 # installing binaries
89 install -o news -g news -m 6755 -D $(STRIP_FLAG) src/noffle $(BUILDDIR)/usr/bin/noffle 72 install -o news -g news -m 6755 -D $(STRIP_FLAG) src/noffle $(BUILDDIR)/usr/bin/noffle
90 install -o root -g root -m 0755 -D debian/noffle-cronfetch $(BUILDDIR)/usr/sbin/noffle-cronfetch 73 install -o root -g root -m 0755 -D debian/noffle-cronfetch $(BUILDDIR)/usr/sbin/noffle-cronfetch
91 74
149 dpkg-shlibdeps $(BUILDDIR)/usr/bin/noffle 132 dpkg-shlibdeps $(BUILDDIR)/usr/bin/noffle
150 dpkg-gencontrol -isp -pnoffle -P$(BUILDDIR) 133 dpkg-gencontrol -isp -pnoffle -P$(BUILDDIR)
151 dpkg --build $(BUILDDIR) .. 134 dpkg --build $(BUILDDIR) ..
152 # binary target finished 135 # binary target finished
153 136
154 .PHONY: clean configure build binary binary-indep binary-arch 137 .PHONY: clean build binary binary-indep binary-arch