comparison debian/rules @ 378:38f082d6856a noffle

[svn] fixed reverse patching
author godisch
date Thu, 10 Apr 2003 16:12:25 +0100
parents 31295db432f5
children e731123d059e
comparison
equal deleted inserted replaced
377:21300895412f 378:38f082d6856a
1 #!/usr/bin/make -f 1 #!/usr/bin/make -f
2 # $Id: rules 509 2003-04-01 13:47:49Z godisch $ 2 # $Id: rules 518 2003-04-10 15:12:25Z godisch $
3 3
4 BUILDDIR = debian/noffle 4 BUILDDIR = debian/noffle
5 DEBDIR = $(BUILDDIR)/DEBIAN 5 DEBDIR = $(BUILDDIR)/DEBIAN
6 DOCDIR = $(BUILDDIR)/usr/share/doc/noffle 6 DOCDIR = $(BUILDDIR)/usr/share/doc/noffle
7 SPOOLDIR = $(BUILDDIR)/var/spool/noffle 7 SPOOLDIR = $(BUILDDIR)/var/spool/noffle
40 clean: 40 clean:
41 $(testdir) 41 $(testdir)
42 rm -f configure-stamp build-stamp debian/files debian/substvars 42 rm -f configure-stamp build-stamp debian/files debian/substvars
43 -$(MAKE) -i distclean 43 -$(MAKE) -i distclean
44 rm -rf debian/noffle 44 rm -rf debian/noffle
45 -cat debian/patches/*.diff | patch -RNtp1 -r debian/rejected --no-backup-if-mismatch 45 -cat `ls -r debian/patches/*.diff` | patch -RNtp1 -r debian/rejected --no-backup-if-mismatch
46 rm -f debian/rejected 46 rm -f debian/rejected
47 47
48 configure-stamp: configure 48 configure-stamp: configure
49 $(testdir) 49 $(testdir)
50 -cat debian/patches/*.diff | patch -Ntp1 -r debian/rejected --no-backup-if-mismatch 50 -cat debian/patches/*.diff | patch -Ntp1 -r debian/rejected --no-backup-if-mismatch