Mercurial > noffle
comparison debian/rules @ 394:3d3a0dab6011 noffle
[svn] small update
author | godisch |
---|---|
date | Sat, 24 May 2003 19:48:30 +0100 |
parents | e731123d059e |
children | 7a5ec3f900e1 |
comparison
equal
deleted
inserted
replaced
393:e113df4af08b | 394:3d3a0dab6011 |
---|---|
1 #!/usr/bin/make -f | 1 #!/usr/bin/make -f |
2 # $Id: rules 519 2003-04-10 15:18:29Z godisch $ | 2 # $Id: rules 536 2003-05-24 18:48:30Z godisch $ |
3 | 3 |
4 BUILDDIR = debian/noffle | 4 BUILDDIR = debian/noffle |
5 DEBDIR = $(BUILDDIR)/DEBIAN | 5 DEBDIR = $(BUILDDIR)/DEBIAN |
6 DOCDIR = $(BUILDDIR)/usr/share/doc/noffle | 6 DOCDIR = $(BUILDDIR)/usr/share/doc/noffle |
7 SPOOLDIR = $(BUILDDIR)/var/spool/noffle | 7 SPOOLDIR = $(BUILDDIR)/var/spool/noffle |
40 clean: | 40 clean: |
41 $(testdir) | 41 $(testdir) |
42 rm -f configure-stamp build-stamp debian/files debian/substvars | 42 rm -f configure-stamp build-stamp debian/files debian/substvars |
43 -$(MAKE) -i distclean | 43 -$(MAKE) -i distclean |
44 rm -rf debian/noffle | 44 rm -rf debian/noffle |
45 -cat `ls -r debian/patches/*.diff` /dev/null | patch -RNtp1 -r debian/rejected --no-backup-if-mismatch | 45 -cat `ls -r debian/patches/*.diff` /dev/null | patch -RENtp1 -r debian/rejected --no-backup-if-mismatch |
46 rm -f debian/rejected | 46 rm -f debian/rejected |
47 | 47 |
48 configure-stamp: configure | 48 configure-stamp: configure |
49 $(testdir) | 49 $(testdir) |
50 -cat debian/patches/*.diff | patch -Ntp1 -r debian/rejected --no-backup-if-mismatch | 50 -cat debian/patches/*.diff | patch -Ntp1 -r debian/rejected --no-backup-if-mismatch |
95 sed 's@/etc/noffle\.conf@/etc/news/noffle.conf@g' docs/noffle.1 > $(MANDIR)/man1/noffle.1 | 95 sed 's@/etc/noffle\.conf@/etc/news/noffle.conf@g' docs/noffle.1 > $(MANDIR)/man1/noffle.1 |
96 sed 's@/etc/noffle\.conf@/etc/news/noffle.conf@g' docs/noffle.conf.5 > $(MANDIR)/man5/noffle.conf.5 | 96 sed 's@/etc/noffle\.conf@/etc/news/noffle.conf@g' docs/noffle.conf.5 > $(MANDIR)/man5/noffle.conf.5 |
97 chown root:root $(MANDIR)/man1/noffle.1 $(MANDIR)/man5/noffle.conf.5 | 97 chown root:root $(MANDIR)/man1/noffle.1 $(MANDIR)/man5/noffle.conf.5 |
98 chmod 0644 $(MANDIR)/man1/noffle.1 $(MANDIR)/man5/noffle.conf.5 | 98 chmod 0644 $(MANDIR)/man1/noffle.1 $(MANDIR)/man5/noffle.conf.5 |
99 install -o root -g root -m 0644 debian/noffle-cronfetch.8 $(MANDIR)/man8 | 99 install -o root -g root -m 0644 debian/noffle-cronfetch.8 $(MANDIR)/man8 |
100 find $(MANDIR) -type f -print0 | xargs -0 gzip -9 | 100 find $(MANDIR) -type f -print0 | xargs -0 gzip -9n |
101 | 101 |
102 # installing documentation | 102 # installing documentation |
103 install -D -o root -g root -m 0644 ChangeLog $(DOCDIR)/changelog | 103 install -D -o root -g root -m 0644 ChangeLog $(DOCDIR)/changelog |
104 install -D -o root -g root -m 0644 debian/changelog $(DOCDIR)/changelog.Debian | 104 install -D -o root -g root -m 0644 debian/changelog $(DOCDIR)/changelog.Debian |
105 install -o root -g root -m 0644 debian/copyright debian/README.Debian AUTHORS NEWS TODO docs/FAQ docs/INTERNALS docs/NOTES $(DOCDIR) | 105 install -o root -g root -m 0644 debian/copyright debian/README.Debian AUTHORS NEWS TODO docs/FAQ docs/INTERNALS docs/NOTES $(DOCDIR) |
106 ln -s ../../noffle $(DOCDIR)/examples | 106 ln -s ../../noffle $(DOCDIR)/examples |
107 install -D -o root -g root -m 0644 debian/xinetd $(DOCDIR)/examples/xinetd.conf | 107 install -D -o root -g root -m 0644 debian/xinetd $(DOCDIR)/examples/xinetd.conf |
108 find $(DOCDIR) -type f \( -size +8 -o -name 'changelog*' \) -print0 | xargs -0 gzip -9 | 108 find $(DOCDIR) -type f \( -size +8 -o -name 'changelog*' \) -print0 | xargs -0 gzip -9n |
109 | 109 |
110 # installing config files | 110 # installing config files |
111 install -d -o root -g root -m 0755 $(BUILDDIR)/etc/news $(BUILDDIR)/etc/default | 111 install -d -o root -g root -m 0755 $(BUILDDIR)/etc/news $(BUILDDIR)/etc/default |
112 install -D -o root -g root -m 0644 debian/cron.d $(BUILDDIR)/etc/cron.d/noffle | 112 install -D -o root -g root -m 0644 debian/cron.d $(BUILDDIR)/etc/cron.d/noffle |
113 install -D -o root -g root -m 0755 debian/cron.daily $(BUILDDIR)/etc/cron.daily/noffle | 113 install -D -o root -g root -m 0755 debian/cron.daily $(BUILDDIR)/etc/cron.daily/noffle |