Mercurial > noffle
comparison debian/rules @ 302:4f4c233374ca noffle
[svn] removed sed
author | godisch |
---|---|
date | Sat, 15 Feb 2003 21:34:21 +0000 |
parents | 3b5b7f3fd71f |
children | 00766bc86962 |
comparison
equal
deleted
inserted
replaced
301:3b5b7f3fd71f | 302:4f4c233374ca |
---|---|
1 #!/usr/bin/make -f | 1 #!/usr/bin/make -f |
2 # $Id: rules 434 2003-02-14 13:54:32Z godisch $ | 2 # $Id: rules 436 2003-02-15 21:34:21Z godisch $ |
3 | 3 |
4 #export MAINT_BUILD=1 | 4 #export MAINT_BUILD=1 |
5 | 5 |
6 BUILDDIR = debian/noffle | 6 BUILDDIR = debian/noffle |
7 DEBDIR = $(BUILDDIR)/DEBIAN | 7 DEBDIR = $(BUILDDIR)/DEBIAN |
144 $(INSTALL) -m 0644 debian/control $(DEBDIR) | 144 $(INSTALL) -m 0644 debian/control $(DEBDIR) |
145 $(INSTALL) -m 0755 debian/postinst $(DEBDIR) | 145 $(INSTALL) -m 0755 debian/postinst $(DEBDIR) |
146 $(INSTALL) -m 0755 debian/postrm $(DEBDIR) | 146 $(INSTALL) -m 0755 debian/postrm $(DEBDIR) |
147 $(INSTALL) -m 0755 debian/preinst $(DEBDIR) | 147 $(INSTALL) -m 0755 debian/preinst $(DEBDIR) |
148 $(INSTALL) -m 0755 debian/prerm $(DEBDIR) | 148 $(INSTALL) -m 0755 debian/prerm $(DEBDIR) |
149 find $(BUILDDIR)/usr -type f -print0 | xargs -0 md5sum | sed 's@ debian/noffle/@ @' > $(DEBDIR)/md5sums | 149 cd $(BUILDDIR) && find usr -type f -print0 | xargs -0 md5sum > DEBIAN/md5sums |
150 find $(BUILDDIR)/etc -type f | sed 's@^debian/noffle@@' | egrep -vx '/etc/default/noffle|/etc/news/noffle\.conf' > $(DEBDIR)/conffiles | 150 cd $(BUILDDIR) && find ./etc -type f | cut -c 2- | egrep -vx '/etc/default/noffle|/etc/news/noffle\.conf' > DEBIAN/conffiles |
151 debconf-mergetemplate debian/templates.?? debian/templates > $(DEBDIR)/templates | 151 debconf-mergetemplate debian/templates.?? debian/templates > $(DEBDIR)/templates |
152 chown root:root $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates | 152 chown root:root $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates |
153 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates | 153 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates |
154 | 154 |
155 # building Debian package | 155 # building Debian package |
156 dpkg-shlibdeps $(BUILDDIR)/usr/bin/noffle | 156 dpkg-shlibdeps $(BUILDDIR)/usr/bin/noffle |
157 dpkg-gencontrol -isp -pnoffle -P$(BUILDDIR) | 157 dpkg-gencontrol -isp -pnoffle -P$(BUILDDIR) |
158 dpkg --build $(BUILDDIR) .. | 158 dpkg --build $(BUILDDIR) .. |
159 | |
160 # binary target finished | 159 # binary target finished |
161 | 160 |
162 .PHONY: clean configure build binary binary-indep binary-arch | 161 .PHONY: clean configure build binary binary-indep binary-arch |