Mercurial > noffle
comparison debian/rules @ 323:67ce1ddf7313 noffle
[svn] cleanup
author | godisch |
---|---|
date | Sat, 22 Feb 2003 21:09:23 +0000 |
parents | 1439f5692d18 |
children | f478d73876e7 |
comparison
equal
deleted
inserted
replaced
322:26fc118999aa | 323:67ce1ddf7313 |
---|---|
1 #!/usr/bin/make -f | 1 #!/usr/bin/make -f |
2 # $Id: rules 442 2003-02-17 17:40:04Z godisch $ | 2 # $Id: rules 458 2003-02-22 21:09:23Z godisch $ |
3 | 3 |
4 #export MAINT_BUILD=1 | 4 #export MAINT_BUILD=1 |
5 | 5 |
6 BUILDDIR = debian/noffle | 6 BUILDDIR = debian/noffle |
7 DEBDIR = $(BUILDDIR)/DEBIAN | 7 DEBDIR = $(BUILDDIR)/DEBIAN |
115 chmod 0644 $(MANDIR)/man1/noffle.1 $(MANDIR)/man5/noffle.conf.5 | 115 chmod 0644 $(MANDIR)/man1/noffle.1 $(MANDIR)/man5/noffle.conf.5 |
116 install -o root -g root -m 0644 debian/noffle-cronfetch.8 $(MANDIR)/man8 | 116 install -o root -g root -m 0644 debian/noffle-cronfetch.8 $(MANDIR)/man8 |
117 find $(MANDIR) -type f -print0 | xargs -0 gzip -9 | 117 find $(MANDIR) -type f -print0 | xargs -0 gzip -9 |
118 | 118 |
119 # installing documentation | 119 # installing documentation |
120 install -d -o root -g root -m 0755 $(DOCDIR) | 120 install -D -o root -g root -m 0644 ChangeLog $(DOCDIR)/changelog |
121 install -o root -g root -m 0644 AUTHORS NEWS TODO docs/FAQ docs/INTERNALS docs/NOTES $(DOCDIR) | 121 install -D -o root -g root -m 0644 debian/changelog $(DOCDIR)/changelog.Debian |
122 install -D -o root -g root -m 0644 debian/changelog $(DOCDIR)/changelog.Debian | 122 install -o root -g root -m 0644 debian/copyright debian/README.Debian AUTHORS NEWS TODO docs/FAQ docs/INTERNALS docs/NOTES $(DOCDIR) |
123 install -D -o root -g root -m 0644 ChangeLog $(DOCDIR)/changelog | |
124 install -o root -g root -m 0644 debian/copyright $(DOCDIR) | |
125 install -o root -g root -m 0644 debian/README.Debian $(DOCDIR) | |
126 ln -s ../../noffle $(DOCDIR)/examples | 123 ln -s ../../noffle $(DOCDIR)/examples |
127 find $(DOCDIR) -type f \( -size +8 -o -name 'changelog*' \) -print0 | xargs -0 gzip -9 | 124 find $(DOCDIR) -type f \( -size +8 -o -name 'changelog*' \) -print0 | xargs -0 gzip -9 |
128 | 125 |
129 # installing config files | 126 # installing config files |
130 install -d -o root -g root -m 0755 $(BUILDDIR)/etc/news $(BUILDDIR)/etc/default | 127 install -d -o root -g root -m 0755 $(BUILDDIR)/etc/news $(BUILDDIR)/etc/default |
137 install -D -o root -g root -m 0644 debian/logcheck $(BUILDDIR)/etc/logcheck/ignore.d.server/noffle | 134 install -D -o root -g root -m 0644 debian/logcheck $(BUILDDIR)/etc/logcheck/ignore.d.server/noffle |
138 install -D -o root -g root -m 0644 debian/logcheck $(BUILDDIR)/etc/logcheck/ignore.d.workstation/noffle | 135 install -D -o root -g root -m 0644 debian/logcheck $(BUILDDIR)/etc/logcheck/ignore.d.workstation/noffle |
139 | 136 |
140 # installing packaging information | 137 # installing packaging information |
141 install -d -o root -g root -m 0755 $(DEBDIR) | 138 install -d -o root -g root -m 0755 $(DEBDIR) |
142 install -o root -g root -m 0755 debian/config $(DEBDIR) | 139 install -o root -g root -m 0644 debian/control $(DEBDIR) |
143 install -o root -g root -m 0644 debian/control $(DEBDIR) | 140 install -o root -g root -m 0755 debian/config debian/preinst debian/postinst debian/prerm debian/postrm $(DEBDIR) |
144 install -o root -g root -m 0755 debian/postinst $(DEBDIR) | |
145 install -o root -g root -m 0755 debian/postrm $(DEBDIR) | |
146 install -o root -g root -m 0755 debian/preinst $(DEBDIR) | |
147 install -o root -g root -m 0755 debian/prerm $(DEBDIR) | |
148 cd $(BUILDDIR) && find usr -type f -print0 | xargs -0 md5sum | tee DEBIAN/md5sums | 141 cd $(BUILDDIR) && find usr -type f -print0 | xargs -0 md5sum | tee DEBIAN/md5sums |
149 cd $(BUILDDIR) && find ./etc -type f | cut -c 2- | tee DEBIAN/conffiles | 142 cd $(BUILDDIR) && find ./etc -type f | cut -c 2- | tee DEBIAN/conffiles |
150 debconf-mergetemplate debian/templates.?? debian/templates > $(DEBDIR)/templates | 143 debconf-mergetemplate debian/templates.?? debian/templates > $(DEBDIR)/templates |
151 chown root:root $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates | 144 chown root:root $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates |
152 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates | 145 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates |