Mercurial > noffle
comparison debian/rules @ 432:7a5ec3f900e1 noffle
[svn] update
author | godisch |
---|---|
date | Mon, 23 Jun 2003 10:00:58 +0100 |
parents | 3d3a0dab6011 |
children | a5cb498bcbed |
comparison
equal
deleted
inserted
replaced
431:cef9370fad90 | 432:7a5ec3f900e1 |
---|---|
1 #!/usr/bin/make -f | 1 #!/usr/bin/make -f |
2 # $Id: rules 536 2003-05-24 18:48:30Z godisch $ | 2 # $Id: rules 575 2003-06-23 09:00:58Z godisch $ |
3 | 3 |
4 BUILDDIR = debian/noffle | 4 BUILDDIR = debian/noffle |
5 DEBDIR = $(BUILDDIR)/DEBIAN | 5 DEBDIR = $(BUILDDIR)/DEBIAN |
6 DOCDIR = $(BUILDDIR)/usr/share/doc/noffle | 6 DOCDIR = $(BUILDDIR)/usr/share/doc/noffle |
7 SPOOLDIR = $(BUILDDIR)/var/spool/noffle | 7 SPOOLDIR = $(BUILDDIR)/var/spool/noffle |
120 | 120 |
121 # installing packaging information | 121 # installing packaging information |
122 install -d -o root -g root -m 0755 $(DEBDIR) | 122 install -d -o root -g root -m 0755 $(DEBDIR) |
123 install -o root -g root -m 0644 debian/control $(DEBDIR) | 123 install -o root -g root -m 0644 debian/control $(DEBDIR) |
124 install -o root -g root -m 0755 debian/config debian/preinst debian/postinst debian/prerm debian/postrm $(DEBDIR) | 124 install -o root -g root -m 0755 debian/config debian/preinst debian/postinst debian/prerm debian/postrm $(DEBDIR) |
125 cd $(BUILDDIR) && find usr -type f -print0 | xargs -0 md5sum | tee DEBIAN/md5sums | 125 cd $(BUILDDIR) && find usr -type f -print0 | xargs -0 md5sum > DEBIAN/md5sums |
126 cd $(BUILDDIR) && find ./etc -type f | cut -c 2- | tee DEBIAN/conffiles | 126 cd $(BUILDDIR) && find ./etc -type f | cut -c 2- > DEBIAN/conffiles |
127 po2debconf debian/templates > $(DEBDIR)/templates | 127 po2debconf debian/templates > $(DEBDIR)/templates |
128 chown root:root $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates | 128 chown root:root $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates |
129 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates | 129 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates |
130 | 130 |
131 # building Debian package | 131 # building Debian package |