Mercurial > noffle
comparison debian/rules @ 486:a5cb498bcbed noffle
[svn] *** empty log message ***
author | godisch |
---|---|
date | Sun, 28 Nov 2004 09:46:27 +0000 |
parents | 7a5ec3f900e1 |
children |
comparison
equal
deleted
inserted
replaced
485:8d6a9b040583 | 486:a5cb498bcbed |
---|---|
1 #!/usr/bin/make -f | 1 #!/usr/bin/make -f |
2 # $Id: rules 575 2003-06-23 09:00:58Z godisch $ | 2 # $Id: rules 633 2004-11-28 09:46:27Z godisch $ |
3 | 3 |
4 BUILDDIR = debian/noffle | 4 BUILDDIR = debian/noffle |
5 DEBDIR = $(BUILDDIR)/DEBIAN | 5 DEBDIR = $(BUILDDIR)/DEBIAN |
6 DOCDIR = $(BUILDDIR)/usr/share/doc/noffle | 6 DOCDIR = $(BUILDDIR)/usr/share/doc/noffle |
7 SPOOLDIR = $(BUILDDIR)/var/spool/noffle | 7 SPOOLDIR = $(BUILDDIR)/var/spool/noffle |
129 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates | 129 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates |
130 | 130 |
131 # building Debian package | 131 # building Debian package |
132 dpkg-shlibdeps $(BUILDDIR)/usr/bin/noffle | 132 dpkg-shlibdeps $(BUILDDIR)/usr/bin/noffle |
133 dpkg-gencontrol -isp -pnoffle -P$(BUILDDIR) | 133 dpkg-gencontrol -isp -pnoffle -P$(BUILDDIR) |
134 chmod 0644 $(BUILDDIR)/DEBIAN/control | |
134 dpkg --build $(BUILDDIR) .. | 135 dpkg --build $(BUILDDIR) .. |
135 # binary target finished | 136 # binary target finished |
136 | 137 |
137 .PHONY: clean build binary binary-indep binary-arch | 138 .PHONY: clean build binary binary-indep binary-arch |