comparison debian/rules @ 307:a6e66cc358e8 noffle

[svn] output md5sums and conffiles
author godisch
date Mon, 17 Feb 2003 17:11:14 +0000
parents 00766bc86962
children 1439f5692d18
comparison
equal deleted inserted replaced
306:52ce87d25641 307:a6e66cc358e8
1 #!/usr/bin/make -f 1 #!/usr/bin/make -f
2 # $Id: rules 439 2003-02-16 15:38:48Z godisch $ 2 # $Id: rules 441 2003-02-17 17:11:14Z godisch $
3 3
4 #export MAINT_BUILD=1 4 #export MAINT_BUILD=1
5 5
6 BUILDDIR = debian/noffle 6 BUILDDIR = debian/noffle
7 DEBDIR = $(BUILDDIR)/DEBIAN 7 DEBDIR = $(BUILDDIR)/DEBIAN
144 $(INSTALL) -m 0644 debian/control $(DEBDIR) 144 $(INSTALL) -m 0644 debian/control $(DEBDIR)
145 $(INSTALL) -m 0755 debian/postinst $(DEBDIR) 145 $(INSTALL) -m 0755 debian/postinst $(DEBDIR)
146 $(INSTALL) -m 0755 debian/postrm $(DEBDIR) 146 $(INSTALL) -m 0755 debian/postrm $(DEBDIR)
147 $(INSTALL) -m 0755 debian/preinst $(DEBDIR) 147 $(INSTALL) -m 0755 debian/preinst $(DEBDIR)
148 $(INSTALL) -m 0755 debian/prerm $(DEBDIR) 148 $(INSTALL) -m 0755 debian/prerm $(DEBDIR)
149 cd $(BUILDDIR) && find usr -type f -print0 | xargs -0 md5sum > DEBIAN/md5sums 149 cd $(BUILDDIR) && find usr -type f -print0 | xargs -0 md5sum | tee DEBIAN/md5sums
150 cd $(BUILDDIR) && find ./etc -type f | cut -c 2- > DEBIAN/conffiles 150 cd $(BUILDDIR) && find ./etc -type f | cut -c 2- | tee DEBIAN/conffiles
151 debconf-mergetemplate debian/templates.?? debian/templates > $(DEBDIR)/templates 151 debconf-mergetemplate debian/templates.?? debian/templates > $(DEBDIR)/templates
152 chown root:root $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates 152 chown root:root $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates
153 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates 153 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates
154 154
155 # building Debian package 155 # building Debian package