Mercurial > noffle
comparison debian/rules @ 327:a9d3ea0478c1 noffle
[svn] fixed permissions of xinetd example
author | godisch |
---|---|
date | Mon, 24 Feb 2003 06:23:50 +0000 |
parents | f478d73876e7 |
children | fa7a42b18bc8 |
comparison
equal
deleted
inserted
replaced
326:f478d73876e7 | 327:a9d3ea0478c1 |
---|---|
1 #!/usr/bin/make -f | 1 #!/usr/bin/make -f |
2 # $Id: rules 461 2003-02-24 06:22:57Z godisch $ | 2 # $Id: rules 462 2003-02-24 06:23:50Z godisch $ |
3 | 3 |
4 #export MAINT_BUILD=1 | 4 #export MAINT_BUILD=1 |
5 | 5 |
6 BUILDDIR = debian/noffle | 6 BUILDDIR = debian/noffle |
7 DEBDIR = $(BUILDDIR)/DEBIAN | 7 DEBDIR = $(BUILDDIR)/DEBIAN |
119 # installing documentation | 119 # installing documentation |
120 install -D -o root -g root -m 0644 ChangeLog $(DOCDIR)/changelog | 120 install -D -o root -g root -m 0644 ChangeLog $(DOCDIR)/changelog |
121 install -D -o root -g root -m 0644 debian/changelog $(DOCDIR)/changelog.Debian | 121 install -D -o root -g root -m 0644 debian/changelog $(DOCDIR)/changelog.Debian |
122 install -o root -g root -m 0644 debian/copyright debian/README.Debian AUTHORS NEWS TODO docs/FAQ docs/INTERNALS docs/NOTES $(DOCDIR) | 122 install -o root -g root -m 0644 debian/copyright debian/README.Debian AUTHORS NEWS TODO docs/FAQ docs/INTERNALS docs/NOTES $(DOCDIR) |
123 ln -s ../../noffle $(DOCDIR)/examples | 123 ln -s ../../noffle $(DOCDIR)/examples |
124 install -D -o root -g root -m 0755 debian/xinetd $(DOCDIR)/examples/xinetd.conf | 124 install -D -o root -g root -m 0644 debian/xinetd $(DOCDIR)/examples/xinetd.conf |
125 find $(DOCDIR) -type f \( -size +8 -o -name 'changelog*' \) -print0 | xargs -0 gzip -9 | 125 find $(DOCDIR) -type f \( -size +8 -o -name 'changelog*' \) -print0 | xargs -0 gzip -9 |
126 | 126 |
127 # installing config files | 127 # installing config files |
128 install -d -o root -g root -m 0755 $(BUILDDIR)/etc/news $(BUILDDIR)/etc/default | 128 install -d -o root -g root -m 0755 $(BUILDDIR)/etc/news $(BUILDDIR)/etc/default |
129 install -D -o root -g root -m 0644 debian/cron.d $(BUILDDIR)/etc/cron.d/noffle | 129 install -D -o root -g root -m 0644 debian/cron.d $(BUILDDIR)/etc/cron.d/noffle |