comparison packages/redhat/noffle.spec @ 110:d23f038454d4 noffle

[svn] First version
author bears
date Sat, 24 Jun 2000 21:20:01 +0100
parents
children 1c7303c71f66
comparison
equal deleted inserted replaced
109:2bedacfe1ba7 110:d23f038454d4
1 Summary: Usenet newsserver for small sites
2 Name: noffle
3 Version: 1.0pre6
4 Release: 4
5 Group: Networking/Daemons
6 Copyright: GPL
7 Packager: Soenke J. Peters <peters+rpm@simprovement.com>
8 URL: http://home.t-online.de/home/markus.enzenberger/noffle.html
9 BuildRoot: /var/tmp/%{name}-%{version}-root
10 Source: http://download.sourceforge.net/noffle/%{name}-%{version}.tar.gz
11 Prefix: /usr
12
13 Requires: gdbm
14 Requires: mailx
15 Requires: textutils
16
17 %description
18 NOFFLE is a news server optimized for low speed dialup connection to the
19 Internet and few users. It allows reading news offline with many news reader
20 programs, even if they do not support offline reading by themselves.
21
22 %prep
23 %setup
24
25 %build
26 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s"
27 export CFLAGS LDFLAGS
28 ./configure --prefix=/usr --enable-debug=no
29 make
30
31 %install
32 install -o 0 -g 0 -d $RPM_BUILD_ROOT/%{prefix}/bin
33 install -s -m 4755 -o news -g news src/noffle $RPM_BUILD_ROOT/%{prefix}/bin
34 install -o 0 -g 0 -d $RPM_BUILD_ROOT/%{prefix}/man/man1
35 install -m 0644 -o 0 -g 0 docs/noffle.1 $RPM_BUILD_ROOT/%{prefix}/man/man1/noffle.1
36 install -o 0 -g 0 -d $RPM_BUILD_ROOT/%{prefix}/man/man5
37 install -m 0644 -o 0 -g 0 docs/noffle.conf.5 $RPM_BUILD_ROOT/%{prefix}/man/man5/noffle.conf.5
38 install -m 2755 -o news -g news -d $RPM_BUILD_ROOT/var/spool/noffle
39 install -o 0 -g 0 -d $RPM_BUILD_ROOT/etc
40 install -o news -g news -d $RPM_BUILD_ROOT/var/spool/noffle/data
41 install -o news -g news -d $RPM_BUILD_ROOT/var/spool/noffle/lock
42 install -o news -g news -d $RPM_BUILD_ROOT/var/spool/noffle/requested
43 install -o news -g news -d $RPM_BUILD_ROOT/var/spool/noffle/outgoing
44 install -o news -g news -d $RPM_BUILD_ROOT/var/spool/noffle/overview
45 install -m 0600 -o news -g news noffle.conf.example $RPM_BUILD_ROOT/etc/noffle.conf
46 install -o 0 -g 0 -d $RPM_BUILD_ROOT/etc/cron.daily
47 install -m 0755 -o news -g news packages/redhat/noffle-expire $RPM_BUILD_ROOT/etc/cron.daily/noffle-expire
48
49 %post
50 # Update /etc/inetd.conf
51 if ! grep -q '^[# \t]*nntp' /etc/inetd.conf ; then
52 echo >> /etc/inetd.conf
53 echo "nntp stream tcp nowait news /usr/sbin/tcpd %{prefix}/bin/noffle -r" >> /etc/inetd.conf
54 if [ -f /var/run/inetd.pid ] ; then
55 kill -HUP `cat /var/run/inetd.pid`
56 fi
57 fi
58 if ! grep -q '^[# \t]*noffle' /etc/hosts.deny ; then
59 echo >> /etc/hosts.deny
60 echo "noffle: ALL EXCEPT LOCAL" >> /etc/hosts.deny
61 fi
62 echo
63 echo " Don't forget to edit /etc/noffle.conf !!! "
64 echo
65
66 %postun
67 # The script gets 0 on uninstall, 1 on upgrade. Don't remove
68 # hosts.deny/inetd.conf lines on upgrade.
69 if [ "$1" = 0 ] ; then
70 if [ -f /etc/inetd.conf ] &&
71 grep noffle /etc/inetd.conf > /dev/null 2>&1 ; then
72 if grep -v noffle /etc/inetd.conf > /tmp/inetd.$$ ; then
73 mv -f /tmp/inetd.$$ /etc/inetd.conf
74 if [ -f /var/run/inetd.pid ] ; then
75 kill -HUP `cat /var/run/inetd.pid`
76 fi
77 fi
78 fi
79 if [ -f /etc/hosts.deny ] &&
80 grep noffle /etc/hosts.deny > /dev/null 2>&1 ; then
81 if grep -v noffle /etc/hosts.deny > /tmp/hosts.deny.$$ ; then
82 mv -f /tmp/hosts.deny.$$ /etc/hosts.deny
83 fi
84 fi
85 fi
86
87 %clean
88 [ "$RPM_BUILD_ROOT" != "" ] && rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %config /etc/noffle.conf
92 %doc README INSTALL ChangeLog docs/FAQ docs/NOTES docs/INTERNALS docs/noffle.lsm COPYING noffle.conf.example
93 %{prefix}/bin/noffle
94 %{prefix}/man/man1/noffle.1
95 %{prefix}/man/man5/noffle.conf.5
96 /etc/cron.daily/noffle-expire
97 %dir /var/spool/noffle
98 %dir /var/spool/noffle/data
99 %dir /var/spool/noffle/lock
100 %dir /var/spool/noffle/requested
101 %dir /var/spool/noffle/outgoing
102 %dir /var/spool/noffle/overview
103
104 %changelog
105 * Sun Jun 18 2000 Jim Hague <jim.hague@am.org>
106 - Version 1.0pre6-3 RPM
107 - Changed /etc/noffle.conf mode to 0600 in case server password is required
108 - Added noffle line to /etc/hosts.deny
109 - Make inetd.conf handling match linuxconf - don't keep old files and only
110 add entries if nntp line is not already present, even if commented out,
111 and only remove conf lines on an uninstall
112
113 * Fri Jun 16 2000 Jim Hague <jim.hague@am.org>
114 - Version 1.0pre6-2 RPM
115 - Added /etc/cron.daily/noffle-expire
116
117 * Thu Jun 15 2000 Jim Hague <jim.hague@am.org>
118 - Version 1.0pre6-1 RPM
119 - Modified SPEC from 1.0pre5
120
121 * Wed May 17 2000 Soenke J. Peters <peters+rpm@simprovement.com>
122 - Version 1.0pre5-1 RPM
123 - built SPEC from scratch
124
125 * Mon Aug 23 1999 Mario Moder <moderm@gmx.net>
126 - Version 1.0pre2-1 Binary only RPM, no SPEC available