comparison debian/rules @ 326:f478d73876e7 noffle

[svn] added xinetd dependency option and example
author godisch
date Mon, 24 Feb 2003 06:22:57 +0000
parents 67ce1ddf7313
children a9d3ea0478c1
comparison
equal deleted inserted replaced
325:c36eb2596531 326:f478d73876e7
1 #!/usr/bin/make -f 1 #!/usr/bin/make -f
2 # $Id: rules 458 2003-02-22 21:09:23Z godisch $ 2 # $Id: rules 461 2003-02-24 06:22:57Z godisch $
3 3
4 #export MAINT_BUILD=1 4 #export MAINT_BUILD=1
5 5
6 BUILDDIR = debian/noffle 6 BUILDDIR = debian/noffle
7 DEBDIR = $(BUILDDIR)/DEBIAN 7 DEBDIR = $(BUILDDIR)/DEBIAN
119 # installing documentation 119 # installing documentation
120 install -D -o root -g root -m 0644 ChangeLog $(DOCDIR)/changelog 120 install -D -o root -g root -m 0644 ChangeLog $(DOCDIR)/changelog
121 install -D -o root -g root -m 0644 debian/changelog $(DOCDIR)/changelog.Debian 121 install -D -o root -g root -m 0644 debian/changelog $(DOCDIR)/changelog.Debian
122 install -o root -g root -m 0644 debian/copyright debian/README.Debian AUTHORS NEWS TODO docs/FAQ docs/INTERNALS docs/NOTES $(DOCDIR) 122 install -o root -g root -m 0644 debian/copyright debian/README.Debian AUTHORS NEWS TODO docs/FAQ docs/INTERNALS docs/NOTES $(DOCDIR)
123 ln -s ../../noffle $(DOCDIR)/examples 123 ln -s ../../noffle $(DOCDIR)/examples
124 install -D -o root -g root -m 0755 debian/xinetd $(DOCDIR)/examples/xinetd.conf
124 find $(DOCDIR) -type f \( -size +8 -o -name 'changelog*' \) -print0 | xargs -0 gzip -9 125 find $(DOCDIR) -type f \( -size +8 -o -name 'changelog*' \) -print0 | xargs -0 gzip -9
125 126
126 # installing config files 127 # installing config files
127 install -d -o root -g root -m 0755 $(BUILDDIR)/etc/news $(BUILDDIR)/etc/default 128 install -d -o root -g root -m 0755 $(BUILDDIR)/etc/news $(BUILDDIR)/etc/default
128 install -D -o root -g root -m 0644 debian/cron.d $(BUILDDIR)/etc/cron.d/noffle 129 install -D -o root -g root -m 0644 debian/cron.d $(BUILDDIR)/etc/cron.d/noffle
129 install -D -o root -g root -m 0755 debian/cron.daily $(BUILDDIR)/etc/cron.daily/noffle 130 install -D -o root -g root -m 0755 debian/cron.daily $(BUILDDIR)/etc/cron.daily/noffle
130 install -D -o root -g root -m 0755 debian/init $(BUILDDIR)/etc/init.d/noffle 131 install -D -o root -g root -m 0755 debian/init $(BUILDDIR)/etc/init.d/noffle
131 install -D -o root -g root -m 0755 debian/ip-up $(BUILDDIR)/etc/ppp/ip-up.d/noffle
132 install -D -o root -g root -m 0755 debian/ip-down $(BUILDDIR)/etc/ppp/ip-down.d/noffle
133 install -D -o root -g root -m 0644 debian/logcheck $(BUILDDIR)/etc/logcheck/ignore.d.paranoid/noffle 132 install -D -o root -g root -m 0644 debian/logcheck $(BUILDDIR)/etc/logcheck/ignore.d.paranoid/noffle
134 install -D -o root -g root -m 0644 debian/logcheck $(BUILDDIR)/etc/logcheck/ignore.d.server/noffle 133 install -D -o root -g root -m 0644 debian/logcheck $(BUILDDIR)/etc/logcheck/ignore.d.server/noffle
135 install -D -o root -g root -m 0644 debian/logcheck $(BUILDDIR)/etc/logcheck/ignore.d.workstation/noffle 134 install -D -o root -g root -m 0644 debian/logcheck $(BUILDDIR)/etc/logcheck/ignore.d.workstation/noffle
135 install -D -o root -g root -m 0755 debian/ip-up $(BUILDDIR)/etc/ppp/ip-up.d/noffle
136 install -D -o root -g root -m 0755 debian/ip-down $(BUILDDIR)/etc/ppp/ip-down.d/noffle
136 137
137 # installing packaging information 138 # installing packaging information
138 install -d -o root -g root -m 0755 $(DEBDIR) 139 install -d -o root -g root -m 0755 $(DEBDIR)
139 install -o root -g root -m 0644 debian/control $(DEBDIR) 140 install -o root -g root -m 0644 debian/control $(DEBDIR)
140 install -o root -g root -m 0755 debian/config debian/preinst debian/postinst debian/prerm debian/postrm $(DEBDIR) 141 install -o root -g root -m 0755 debian/config debian/preinst debian/postinst debian/prerm debian/postrm $(DEBDIR)