comparison debian/rules @ 338:fa7a42b18bc8 noffle

[svn] transition to po-debconf
author godisch
date Tue, 04 Mar 2003 20:47:54 +0000
parents a9d3ea0478c1
children 31295db432f5
comparison
equal deleted inserted replaced
337:1aa1ed030464 338:fa7a42b18bc8
1 #!/usr/bin/make -f 1 #!/usr/bin/make -f
2 # $Id: rules 462 2003-02-24 06:23:50Z godisch $ 2 # $Id: rules 474 2003-03-04 20:47:54Z godisch $
3 3
4 #export MAINT_BUILD=1 4 #export MAINT_BUILD=1
5 5
6 BUILDDIR = debian/noffle 6 BUILDDIR = debian/noffle
7 DEBDIR = $(BUILDDIR)/DEBIAN 7 DEBDIR = $(BUILDDIR)/DEBIAN
139 install -d -o root -g root -m 0755 $(DEBDIR) 139 install -d -o root -g root -m 0755 $(DEBDIR)
140 install -o root -g root -m 0644 debian/control $(DEBDIR) 140 install -o root -g root -m 0644 debian/control $(DEBDIR)
141 install -o root -g root -m 0755 debian/config debian/preinst debian/postinst debian/prerm debian/postrm $(DEBDIR) 141 install -o root -g root -m 0755 debian/config debian/preinst debian/postinst debian/prerm debian/postrm $(DEBDIR)
142 cd $(BUILDDIR) && find usr -type f -print0 | xargs -0 md5sum | tee DEBIAN/md5sums 142 cd $(BUILDDIR) && find usr -type f -print0 | xargs -0 md5sum | tee DEBIAN/md5sums
143 cd $(BUILDDIR) && find ./etc -type f | cut -c 2- | tee DEBIAN/conffiles 143 cd $(BUILDDIR) && find ./etc -type f | cut -c 2- | tee DEBIAN/conffiles
144 debconf-mergetemplate debian/templates.?? debian/templates > $(DEBDIR)/templates 144 po2debconf debian/templates > $(DEBDIR)/templates
145 chown root:root $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates 145 chown root:root $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates
146 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates 146 chmod 0644 $(DEBDIR)/md5sums $(DEBDIR)/conffiles $(DEBDIR)/templates
147 147
148 # building Debian package 148 # building Debian package
149 dpkg-shlibdeps $(BUILDDIR)/usr/bin/noffle 149 dpkg-shlibdeps $(BUILDDIR)/usr/bin/noffle