diff src/Makefile.am @ 43:2842f50feb55 noffle

[svn] * client.c, client.h, common.h, config.c, config.h, content.c, content.h, control.c, control.h, database.c, database.h, dynamicstring.c, dynamicstring.h, fetch.c, fetch.h, fetchlist.c, fetchlist.h, group.c, group.h, itemlist.c, itemlist.h, lock.c, lock.h, log.c, log.h, noffle.c, online.c, online.h, outgoing.c, outgoing.h, over.c, over.h, post.c, post.h, protocol.c, protocol.h, pseudo.c, pseudo.h, request.c, request.h, server.c, server.h, util.c, util.h, wildmat.c, wildmat.h: Moved files to the subdirectory src/ * Makefile.am, acconfig.h, configure.in, docs/Makefile.am, src/Makefile.am, Makefile.in, aclocal.m4, config.h.in, configure, install-sh, missing, mkinstalldirs, stamp-h.in, docs/Makefile.in, src/Makefile.in: Added files. They are used by aclocal, autoheader, autoconf and automake. * src/config.c, src/config.h: Renamed to configfile.c and configfile.h, because configure will generate a config.h file itself. * src/client.c, src/content.c, src/database.c, src/fetch.c, src/fetchlist.c, src/group.c, src/lock.c, src/noffle.c, src/online.c, src/outgoing.c, src/over.c, src/pseudo.c, src/request.c, src/server.c, src/util.c: Changed '#include "config.h"' to '#include "configfile.h"'. * src/client.c, src/content.c, src/database.c, src/fetch.c, src/fetchlist.c, src/group.c, src/lock.c, src/online.c, src/outgoing.c, src/post.c, src/protocol.c, src/request.c, src/server.c: Files now #include <config.h>. Added missing <stdio.h>. This removes the warnings about snprintf() not being declared. * Makefile: Removed. This is now generated by configure.
author uh1763
date Fri, 05 May 2000 22:45:56 +0100
parents
children 40a7493238e8
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/Makefile.am	Fri May 05 22:45:56 2000 +0100
@@ -0,0 +1,36 @@
+# This Makefile.am is used by automake to generate the Makefile.in,
+# which in turn will be used to generate the Makefile.
+
+bin_PROGRAMS = noffle
+
+noffle_SOURCES = \
+client.c client.h \
+common.h \
+configfile.c configfile.h \
+content.c content.h \
+control.c control.h \
+database.c database.h \
+dynamicstring.c dynamicstring.h \
+fetch.c fetch.h \
+fetchlist.c fetchlist.h \
+group.c group.h \
+itemlist.c itemlist.h \
+lock.c lock.h \
+log.c log.h \
+noffle.c \
+online.c online.h \
+outgoing.c outgoing.h \
+over.c over.h \
+post.c post.h \
+protocol.c protocol.h \
+pseudo.c pseudo.h \
+request.c request.h \
+server.c server.h \
+util.c util.h \
+wildmat.c wildmat.h
+
+noffle_LDADD = -lgdbm
+
+tags:
+	etags $(noffle_SOURCES)
+