diff configure.in @ 56:688bd51704e0 noffle

[svn] * configure, configure.in: Only add all those compiler-switches like -ansi, -pedantic etc. if we use gcc. Other c-compilers are unlikely to have those switches.
author uh1763
date Fri, 12 May 2000 09:20:00 +0100
parents 48b7f28c3189
children ce8191c38f44
line wrap: on
line diff
--- a/configure.in	Tue May 09 23:32:33 2000 +0100
+++ b/configure.in	Fri May 12 09:20:00 2000 +0100
@@ -132,7 +132,7 @@
   --enable-debug          turn on debugging (default=yes)], ,
 enable_debug=yes)
 
-if test "x$enable_debug" = "xyes"
+if test "x$enable_debug" = "xyes" && test "x$GCC" = "xyes" 
 then
  CFLAGS="$CFLAGS \
 -Wall -O2 -g -pedantic -ansi -W -Wtraditional -Wshadow -Wpointer-arith \