diff Makefile.am @ 200:a34620942998 noffle

[svn] Minor fix needed by configure option --with-configfile. Fixed --program-prefix.
author mirkol
date Thu, 08 Nov 2001 20:51:05 +0000
parents 2842f50feb55
children 9fb4b7d7e64b
line wrap: on
line diff
--- a/Makefile.am	Thu Nov 08 20:47:11 2001 +0000
+++ b/Makefile.am	Thu Nov 08 20:51:05 2001 +0000
@@ -21,19 +21,19 @@
 	$(INSTALL_DATA) -o 0 -g 0 $(srcdir)/README $(DOCDIR)
 	$(INSTALL_DATA) -o 0 -g 0 $(srcdir)/TODO $(DOCDIR)
 	$(INSTALL_DATA) -o 0 -g 0 $(srcdir)/noffle.conf.example \
-                                  /etc/noffle.conf.example
-	chown news.news /etc/noffle.conf.example
-	chmod 600 /etc/noffle.conf.example
+                                  $(CONFIGFILE).example
+	chown news.news $(CONFIGFILE).example
+	chmod 600 $(CONFIGFILE).example
 	@echo
 	@echo "****************************************************************"
-	@echo "You should now copy /etc/noffle.conf.example to /etc/noffle.conf"
+	@echo "You should now copy $(CONFIGFILE).example to $(CONFIGFILE)"
 	@echo "and edit that copy."
 	@echo "****************************************************************"
 	@echo
 
 install-exec-local:
-	chown news.news $(bindir)/$(PACKAGE)
-	chmod 4755 $(bindir)/$(PACKAGE)
+	chown news.news $(bindir)/`echo $(PACKAGE)|sed '$(transform)'`
+	chmod 4755 $(bindir)/`echo $(PACKAGE)|sed '$(transform)'`
 
 uninstall-local:
 	rm -f $(DOCDIR)/AUTHORS
@@ -43,7 +43,7 @@
 	rm -f $(DOCDIR)/NEWS
 	rm -f $(DOCDIR)/README
 	rm -f $(DOCDIR)/TODO
-	rm -f /etc/noffle.conf.example
+	rm -f $(CONFIGFILE).example
 	@echo
 	@echo "****************************************************************"
 	@echo "The NOFFLE spool directory $(SPOOLDIR) and the configfile"