diff configure.in @ 101:ce8191c38f44 noffle

[svn] * configure, configure.in: Changed the --enable-debug option of configure. It now accepts the parameters 'no', 'min' and 'yes', i.e. no compiler- warnings, minimum compiler-warnings and maximum compiler-warnings. Default is 'min'. Stable releases should have 'no' as default, IHMO. * NEWS: Update.
author uh1763
date Mon, 29 May 2000 17:35:01 +0100
parents 688bd51704e0
children 8eb2975c8c1a
line wrap: on
line diff
--- a/configure.in	Fri May 26 10:46:29 2000 +0100
+++ b/configure.in	Mon May 29 17:35:01 2000 +0100
@@ -129,17 +129,28 @@
 
 AC_ARG_ENABLE(debug, [
 NOFFLE options:
-  --enable-debug          turn on debugging (default=yes)], ,
-enable_debug=yes)
+  --enable-debug=[no/min/yes] turn on debugging [default=min]], ,
+enable_debug=min)
 
-if test "x$enable_debug" = "xyes" && test "x$GCC" = "xyes" 
-then
+if test "x$enable_debug" = "xyes" && test "x$GCC" = "xyes"; then
  CFLAGS="$CFLAGS \
 -Wall -O2 -g -pedantic -ansi -W -Wtraditional -Wshadow -Wpointer-arith \
 -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion \
 -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes \
 -Wmissing-declarations -Wnested-externs -Winline \
 -D__USE_BSD -D__USE_XOPEN_EXTENDED -D__USE_POSIX -DDEBUG" 
+else
+
+ dnl Do nothing if --enable-debug=no
+
+ if test "x$enable_debug" != "xno" && test "x$GCC" = "xyes"; then
+  CFLAGS="$CFLAGS \
+-Wall -O2 -g -pedantic -ansi -W -Wtraditional -Wshadow \
+-Wcast-qual -Wcast-align -Wwrite-strings \
+-Waggregate-return -Wstrict-prototypes -Wmissing-prototypes \
+-Wmissing-declarations -Wnested-externs -Winline \
+-D__USE_BSD -D__USE_XOPEN_EXTENDED -D__USE_POSIX -DDEBUG" 
+ fi
 fi