diff configure.in @ 272:f3b44be9e4ab noffle

[svn] * configure.in: Remove '-ansi' and '-Wtraditional'. We use functions that aren't strict ANSI, and I'm not interested in warnings about usage differences between ANSI and K&R. * Makefile.in,aclocal.m4,config.h.in,configure,src/Makefile.in: Regenerate after configure.in change. With all the above in, we now compile cleanly on Cygwin with GCC 3.2, except for a warning about printing a time_t with a %ld format. This will serve as a reminder that we assume time_t is the same size as a long.
author bears
date Sun, 10 Nov 2002 11:44:18 +0000
parents 1cafe0f3f0ec
children 1fdde6512033
line wrap: on
line diff
--- a/configure.in	Sun Nov 10 11:32:17 2002 +0000
+++ b/configure.in	Sun Nov 10 11:44:18 2002 +0000
@@ -133,7 +133,7 @@
 if test "x$enable_debug" = "xyes"; then
   if test "x$GCC" = "xyes"; then
     CFLAGS="$CFLAGS \
-      -Wall -pedantic -ansi -W -Wtraditional -Wshadow -Wpointer-arith \
+      -Wall -pedantic -W -Wshadow -Wpointer-arith \
       -Wcast-align -Wwrite-strings \
       -Wstrict-prototypes -Wmissing-prototypes \
       -Wmissing-declarations -Wnested-externs -Winline \