diff configure.in @ 146:fd821441f016 noffle

[svn] Applied patch by Paul Slootman: using the mail program is replaced by sendmail (SENDMAILPROG variable).
author enz
date Sun, 15 Oct 2000 18:23:27 +0100
parents ffb8a4a91218
children 98bbe33d13b8
line wrap: on
line diff
--- a/configure.in	Sun Oct 15 18:22:42 2000 +0100
+++ b/configure.in	Sun Oct 15 18:23:27 2000 +0100
@@ -28,17 +28,12 @@
 AC_PROG_INSTALL
 AC_PROG_MAKE_SET
 
-AC_CHECK_PROG(MAILPROG, mail, mail)
-if test "x$MAILPROG" != "xmail"; then
- AC_MSG_ERROR(mail program not found.)
+AC_PATH_PROG(SENDMAILPROG, sendmail, 'notfound',
+             /usr/sbin:/usr/lib:$PATH)
+if test "x$SENDMAILPROG" = "xnotfound"; then
+ AC_MSG_ERROR(sendmail program not found in /usr/lib:/usr/sbin:$PATH .)
 fi
 
-AC_CHECK_PROG(SORTPROG, sort, sort)
-if test "x$SORTPROG" != "xsort"; then
- AC_MSG_ERROR(sort program not found.)
-fi
-
-
 dnl ---------------------------------------------------------------------------
 dnl System checks.
 dnl ---------------------------------------------------------------------------
@@ -200,6 +195,7 @@
 DOCDIR=$noffle_cv_docdir
 AC_SUBST(DOCDIR)
 
+AC_DEFINE_UNQUOTED(SENDMAILPROG, "$SENDMAILPROG")
 
 dnl ---------------------------------------------------------------------------
 dnl Output files.