diff configure.in @ 185:fed1334d766b noffle

[svn] * src/client.c: Change variable only used on constant to 'const'. * src/filter.c: Add a couple of 'return's after ASSERT() to remove compiler warnings about functions needing returns. * NEWS,TODO,configure,configure.in,noffle.conf.example,docs/NOTES, docs/noffle.conf.5,src/client.c,src/configfile.c,src/content.c, src/control.c,src/database.c,src/fetch.c,src/fetchlist.c,src/filter.c, src/group.c,src/lock.c,src/log.c,src/log.h,src/noffle.c,src/outgoing.c, src/post.c,src/protocol.c,src/request.c,src/server.c,src/util.c: Debug logging is always compiled and selected via noffle.conf. All debug logs are classified as all, none, config, control, expire, fetch, filter, newsbase, noffle, post, protocol, requests and server.
author bears
date Sun, 05 Aug 2001 09:24:22 +0100
parents 98bbe33d13b8
children 79e324213734
line wrap: on
line diff
--- a/configure.in	Tue Jun 19 11:23:43 2001 +0100
+++ b/configure.in	Sun Aug 05 09:24:22 2001 +0100
@@ -124,28 +124,18 @@
 
 AC_ARG_ENABLE(debug, [
 NOFFLE options:
-  --enable-debug=[no/min/yes] turn on debugging [default=min]], ,
-enable_debug=min)
+  --enable-debug=[no/yes] build with debugging [default=no]], ,
+enable_debug=no)
 
 if test "x$enable_debug" = "xyes" && test "x$GCC" = "xyes"; then
  CFLAGS="$CFLAGS \
 -Wall -O2 -g -pedantic -ansi -W -Wtraditional -Wshadow -Wpointer-arith \
--Wcast-qual -Wcast-align -Wwrite-strings -Wconversion \
--Waggregate-return -Wstrict-prototypes -Wmissing-prototypes \
--Wmissing-declarations -Wnested-externs -Winline \
--D__USE_BSD -D__USE_XOPEN_EXTENDED -D__USE_POSIX -DDEBUG"
-else
-
- dnl Do nothing if --enable-debug=no
-
- if test "x$enable_debug" != "xno" && test "x$GCC" = "xyes"; then
-  CFLAGS="$CFLAGS \
--Wall -O2 -g -pedantic -ansi -W -Wtraditional -Wshadow \
 -Wcast-align -Wwrite-strings \
 -Wstrict-prototypes -Wmissing-prototypes \
 -Wmissing-declarations -Wnested-externs -Winline \
--D__USE_BSD -D__USE_XOPEN_EXTENDED -D__USE_POSIX -DDEBUG"
- fi
+-D__USE_BSD -D__USE_XOPEN_EXTENDED -D__USE_POSIX"
+else
+  CFLAGS="$CFLAGS -D__USE_BSD -D__USE_XOPEN_EXTENDED -D__USE_POSIX"
 fi